Bosch 520 doesn't produce hot water

Bosch 520 doesn't produce hot water

by May
(Montreal)

Hi, I live in Montreal, Canada and I just bought the house with the Bosch tankless water heater, model 520 installed, which uses the hydro generator feature. What I understood is that the heater doesn't need an electricity to run, water flow is enough. The problem is that I don't see any sparks when hot water tap is open. Help please.

Comments for Bosch 520 doesn't produce hot water

Average Rating starstarstarstarstar

Click here to add your own comments

Jul 15, 2013
Rating
starstarstarstarstar
hydrogenerator problem
by: Sean

One of the main reasons when the Bosch water heater is not generating sparks / doesn't lit the burner is the hydrogenerator malfunction, a small turbine whose work is initiated by the water pressure.

To check its proper work, simply use the multimeter and measure the voltage. Make sure the button on control box is in ON position, disconnect the wire connector at the hydro generator and measure. The reading should be 1.3 V DC or 2.8 V AC which depends on the wire color found. If the result is different then the hydrogenerator has to be replaced.

In order to remove / replace hydrogenerator, first turn the gas and water to the heater OFF. Drain the unit and remove the retaining clip from the bushing found on the water valve.

Remove the bushing, disconnect connector, a pin and another clip to disconnect piping. The hydrogenerator is now free and ready for either cleaning or replacement. To replace the element use the same guide but in reverse order.


Another reason when the spark is not generated is when there is a crossover, or when the hot and cold pipes are not properly installed (the pipes are mixed - not in the right order - should be hot-hot; cold-cold).


Click here to add your own comments

Join in and write your own page! It's easy to do. How? Simply click here to return to Bosch.

water heaters